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Trouble saving trusted device?

When logging in to your account, you select "I trust this device, keep me logged in" but your computer is not saved as a trusted device and you are prompted to input your login credentials the next time you try to log in from the same device.

Cause

In LogMeIn Pro, if Two-factor authentication is enabled under Users > Login Policy by the Master Account Holder, the Login Policy does not allow you to save devices.

Action/Workaround

Contact your account's Master Account Holder and request that they change the Login process to Standard.

Article last updated: 27 September, 2022