Hamachi is not installing the Hamachi Network Adapter. What can I do?
You have remove the Hamachi driver files or manually install the Hamachi Network adapter to resolve the issue.
Symptom
When trying to install the Hamachi adapter, you see the following error:
There is no hash in the specified catalog file. The file may be corrupted or tampered with.
Cause
When the
- sys file
- inf file
- cat file
The adapters are located in C:\Program Files (x86)\LogMeIn Hamachi\x64 (for 64-bit systems) or C:\Program Files\LogMeIn Hamachi (for 32-bit systems).
Solution One: Remove the Hamachi driver files
Tip: Before proceeding, you need to have hidden files visible in Windows. Go to to set hidden files to visible.
- Uninstall Hamachi.
- Restart your computer.
- Verify the .sys, .inf, and .cat files are removed from C:\Program Files (x86)\LogMeIn Hamachi\x64 (for 64-bit systems) or C:\Program Files\LogMeIn Hamachi (for 32-bit systems).
- If they are, download and install Hamachi for Windows (MSI).
- If they are not, manually delete the files then download and install Hamachi for Windows (MSI).
Solution Two: Manually install the network adapter
- Go to
- If it begins searching immediately, let it finish, then choose Yes, I have already connected the hardware.
- If it displays the currently installed devices, scroll down to the bottom.
, and type hdwwiz.cpl. If you receive an error, or your computer runs on Windows 7 or Vista, try again with hdwwiz only.
- Choose Add a new hardware device. If it is not there, go to the next step.
- Choose Install the hardware that I manually select from a list (Advanced).
- Select Network adapters.
- Click Have Disk and then Browse.
- Browse to the installation folder, and select the setup information file for your system.
- hamachi.inf: Windows XP, Vista, 2003, 7, 2008 and 2008R2
- hamdrv.inf: Windows 8 and above
- Select the driver based on your system
- Hamachi Network Interface: Windows XP, 2003,
- Hamachi Virtual Ethernet Adapter: Windows Vista and above
- Finish the installation of the adapter.
- Check your Network Connections folder and see if Hamachi's adapter is called Hamachi, and not something like Local Area Connection 4. If it is not named Hamachi, then rename it to Hamachi and try running the application again. Make sure that Network Connection Hamachi is activated.
Important: If your anti-virus software reports or blocks Hamachi-2-ui.exe, you must add an exclusion for the Hamachi-2-ui.exe program. Please consult your anti-virus software documentation for assistance with adding an exclusion to the allowed list.