Using LogMeIn Central on headless computers (with no monitor attached)
Headless computers can be controlled just as any other computer running Host software.
Symptom
When connected to a headless host, you see a blank screen or you are forced to use 640x480 resolution and are unable to change it.
Cause
No display adapters are installed on the headless host.
When LogMeIn Central is installed on a host computer, it installs the Mirror Driver under .
The role of the Mirror Driver is to reproduce the host screen and send it through to the client. In the case of a headless host, it may happen that no display adapter was ever installed, therefore the Mirror Driver has nothing to reproduce.
Solution
Install display adapters on the host. For details and instructions, see the Microsoft Support site.
If your computer already has display adapters installed, you may need to update the existing drivers:
- Open the Device Manager (on Windows 10, type Windows key + X).
- Under Display Adapters, right-click your display adapter (not the Mirror Driver) and select Update Driver Software....
- Select Search automatically for update driver software.
- If an update is found, update your driver. You may be prompted to restart your machine.