Why do I receive 'Another version of this product is already installed'?
When the Windows Registry detects inconsistency, you cannot fully uninstall the host software.
Symptom
Another version of this product is already installed. Installation of this version cannot continue.
Cause
This issue is typically due to a corruption or inconsistency in the local database Windows uses to keep track of installed software.
Resolution
- Press the Windows key + R. The Run box is displayed.
- Type regedit and click Ok.
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\
- Click on each key, until you find one that has Product Name set as RemotelyAnywhere, Pro, or Hamachi in the right pane.
- Delete the selected key.
- Reboot the PC.
- Reinstall the software using a link from here.
After the installation is complete, you can now uninstall the software using the Windows Control Panel.