RemotelyAnywhere System Requirements

The following operating systems are supported both on the host and client computers:

  • Windows 8/8.1
  • Windows 7
  • Windows Vista
  • Windows XP
  • Windows Server 2012/R2
  • Windows Server 2008/R2
  • Windows Server 2003 (all including 64-bit)

To open RemotelyAnywhere on the client computer, you must have a web browser that is compatible with the LogMeIn plugin, such as Internet Explorer.