FAQ

Does LogMeIn work with older processors (pre-SSE2)?

Issue

Objective

Environment

Procedure

Answer


The latest LogMeIn software only supports  SSE2-capable processor architectures. All modern processors support SSE2 since Intel Pentium 4 (2001) and AMD Opteron/Athlon64 (2003).
To install LogMeIn on an older PC, download the latest legacy build from  https://secure.logmein.com/LMI4012704nh.msi.
 
 

Cause

Resolution

Additional Information