HELP FILE

System Requirements for Outlook Plugin

Please check to see that you meet the minimum system requirements before downloading the latest version of the OpenVoice Outlook Plugin.

* Required for Outlook 2016 or later only