TROUBLESHOOTING

Nothing Happens When Opening the GoToMeeting Application

Issue

(End Processes) Control Panel does not appear even though the online interface shows meeting is in session.

Objective

Environment

  • GoToMeeting
  • GoToWebinar
  • GoToTraining
  • Windows

Procedure

Answer

Cause

This issue may be caused by stuck processes related to a previous instance of GoToMeeting that did not close correctly.

Resolution

To force quit GoToMeeting follow the instructions below:


  1. Right click on an open area of your task bar
  2. Click Start Task Manager

User-added image
  1. Click the Processes tab
  2. Click Image Name to sort processes in alphabetical order.
  3. Select a process that starts with g2m and end the process
  4. Repeat until there are no more g2m processes
  5. Close the Task Manager

You should now be able to successfully launch GoToMeeting/Webinar/Training and see the control panel.
Below is a screenshot of what the GoToMeeting processes look like in the Windows Task Manager :

Task Manager

Additional Information

This solution also applies to GoToWebinar and GoToTraining