TROUBLESHOOTING

Error: 'We're sorry! You need to update your Flash Player' in Chrome when trying to view recordings

Issue

  • Error trying to view webinar/training recording in Chrome browser
  • Error: 'We're sorry! You need to update your Flash Player'
  • Able to play recording in other browsers successfully
Flash error

Objective

Environment

  • GoToWebinar
  • GoToTraining
  • Recording playback
  • Chrome

Procedure

Answer

Cause

Chrome has started to automatically block flash content as a security measure.

Resolution

You can enable Chrome to play Flash content automatically or to prompt the user to allow Flash to play or use an alternate browser.

To change your Chrome's Flash settings:
1. Click the User-added image menu icon at the top right of your Chrome browser
2. Select Settings
3. Click Show advanced settings...
4. Under Privacy click Content Settings...
5. Under Flash select Allow Sites to run Flash or Ask first before allowing sites to run Flash (recommended)

Flash settings
6. Click Done
7. Reload the recording playback page and the recording should now play successfully

Additional Information