TROUBLESHOOTING

Unable To Connect To GoToAssist Corporate Session On Windows

Issue

Customer is unable to run the GoToAssist Corporate software on their windows computer

Objective

Environment

  • Windows
  • GoToAssist Corporate

Procedure

Answer

Cause

Some users may not be able to launch the software from www.g2help.com due to firewall or security settings in their environment

Resolution

  1. Link: G2AC Windows
  2. Download GoToAssist Corporate.
  3. Run the software
  4. Provide customer 9 digit code
  5. Click Start Support Session

Additional Information